有时会有中英文混合文本,拆分的话,普通拆分可是会因为中文英文长度占用字节不同而出现乱码,这个时候就需要使用额外的函数逐字分割才能得到正确的结果,源码如下:

.版本 2
.子程序 逐字分割
.参数 欲取的内容, 文本型, , 欲取的内容
.参数 返回的数组, 文本型, 数组, 存储数组变量
.局部变量 n, 整数型
.局部变量 代码, 整数型
.局部变量 临时, 文本型
.局部变量 i, 整数型
.局部变量 返回文本, 文本型
清除数组 (返回的数组)
n = 1
欲取的内容 = 到半角 (欲取的内容)
.判断循环首 (n ≤ 取文本长度 (欲取的内容))
临时 = 取文本中间 (欲取的内容, n, 1)
.如果真 (取代码 (临时, ) < 0)
临时 = 取文本中间 (欲取的内容, n, 2)
n = n + 1
.如果真结束
加入成员 (返回的数组, 临时)
n = n + 1
.判断循环尾 ()

源码整理自:http://www.5a5x.com/06/201505/052911969.html

Related Posts: 易语言 分隔中文英文 逐字分割 :