.版本 2
.子程序 _按钮2_被单击
.局部变量 文件号, 整数型
.局部变量 内容, 文本型
.局部变量 寻找位置, 整数型
.局部变量 换行位置数组, 整数型, , "0"
文件号 = 打开文件 (取运行目录 () + “\回复询盘列表配置.txt”, 6, 1)
内容 = 读入文本 (文件号, )
寻找位置 = 寻找文本 (内容, #换行符, 0, 假)
输出调试文本 (寻找位置)
移动读写位置 (文件号, #文件首, 0)
删除数据 (文件号, 寻找位置 + 1)
关闭文件 (文件号)

实现方式是定位到指定行的换行符(上述代码是默认删除第一行的,其他行如第三行的话,可以根据第二行和第三行的换行代码得出长度,来删除,举一反三吧亲)

Related Posts: 易语言-删除指定行例程 :