内容来自:泪闯天涯曾经写的例程
源码如下:

.版本 2
.子程序 取元素横坐标, 整数型
.参数 元素对象, 对象
.局部变量 元素坐标, 整数型
.局部变量 元素父对象, 对象
元素坐标 = 元素对象.读数值属性 (“offsetLeft”, )
元素父对象 = 元素对象.读对象型属性 (“offsetParent”, )
.如果真 (元素父对象.是否为空 () = 假)
元素坐标 = 元素坐标 + 取元素横坐标 (元素父对象)
.如果真结束
返回 (元素坐标)

.子程序 取元素纵坐标, 整数型
.参数 元素对象, 对象
.局部变量 元素坐标, 整数型
.局部变量 元素父对象, 对象
元素坐标 = 元素对象.读数值属性 (“offsetTop”, )
元素父对象 = 元素对象.读对象型属性 (“offsetParent”, )
.如果真 (元素父对象.是否为空 () = 假)
元素坐标 = 元素坐标 + 取元素纵坐标 (元素父对象)
.如果真结束
返回 (元素坐标)

至于对象的获取,可以参考易语言-网页操作类以及网页文档类中元素的遍历

Related Posts: 易语言-取网页元素坐标示例 :