网页操作类以及网页文档类中元素的遍历
源码如下:

.版本 2
.程序集 窗口程序集1
.程序集变量 集合, 对象
.程序集变量 对象, 对象
.程序集变量 局部_计次, 整数型
.程序集变量 网页文档, 网页文档类
.子程序 __启动窗口_创建完毕
集合 = 网页文档.取元素集合 (“input”)
.计次循环首 (集合.读数值属性 (“length”, ), 局部_计次) ' 这个不要改
对象 = 集合.对象型方法 (“item”, 局部_计次 - 1) ' 这个也不要改
.如果真 (对象.读数值属性 (“maxLength”, ) = 100)
网页文档.置元素文本 (对象, “test”)
对象.方法 (“click”, )
跳出循环 ()
.如果真结束
.计次循环尾 ()

.子程序 网页操作类示例
.局部变量 网页操作类, 网页操作类
集合 = 网页操作类.对象_取对象集合 (“span”)
.计次循环首 (集合.读数值属性 (“length”, ), 局部_计次) ' 这个不要改
对象 = 集合.对象型方法 (“item”, 局部_计次 - 1) ' 这个也不要改
.如果真 (寻找文本 (对象.读文本属性 (“outerHTML”, ), “class=g”, , 假) > -1)
.如果真 (寻找文本 (网页操作类.对象操作_取文本 (对象), “:”, , 假) > -1)
' 对象.方法 (“click”, )
.如果真结束
跳出循环 ()
.如果真结束
.计次循环尾 ()

类似JavaScript的功能

tags = document.getElementsByTagName("div");
for(var i=0;i<tags.length;i++){
tags[i].style.display="none";
}

Related Posts: 易语言-网页操作类以及网页文档类中元素的遍历 :