.版本 2
.子程序 _按钮1_被单击
.局部变量 文件号, 整数型
.局部变量 内容, 文本型
.局部变量 寻找位置, 整数型
.局部变量 出现次数, 整数型
.局部变量 换行位置数组, 整数型, , "0"
文件号 = 打开文件 (取运行目录 () + “\回复询盘列表配置.txt”, 6, 1)
内容 = 读入文本 (文件号, )
出现次数 = 0
.循环判断首 ()
寻找位置 = 寻找文本 (内容, #换行符, 寻找位置 + 1, 假)
.如果 (寻找位置 > -1)
加入成员 (换行位置数组, 寻找位置)
出现次数 = 出现次数 + 1
.否则
跳出循环 ()
.如果结束
.循环判断尾 (真)
输出调试文本 (出现次数)
置随机数种子 ()
移动读写位置 (文件号, #文件首, 换行位置数组 [取随机数 (1, 出现次数)] + 1)
插入文本行 (文件号, “dsdfdsfdftre@df.com”)
关闭文件 (文件号)

Related Posts: 易语言-读入文本例程代码 :