.版本 2
.子程序 取当前CST时间, 文本型
.局部变量 年, 文本型
.局部变量 月, 文本型
.局部变量 日, 文本型
.局部变量 时, 文本型
.局部变量 分, 文本型
.局部变量 秒, 文本型
.局部变量 星期, 文本型
.局部变量 时间, 日期时间型
时间 = 取现行时间 ()
年 = 到文本 (取年份 (时间))
月 = 到文本 (取月份 (时间))
日 = 到文本 (取日 (时间))
时 = 到文本 (取小时 (时间))
分 = 到文本 (取分钟 (时间))
秒 = 到文本 (取秒 (时间))
星期 = 到文本 (取星期几 (时间))
.判断开始 (星期 = “1”)
星期 = “Sun”
.判断 (星期 = “7”)
星期 = “Sat”
.判断 (星期 = “6”)
星期 = “Fri”
.判断 (星期 = “5”)
星期 = “Thu ”
.判断 (星期 = “4”)
星期 = “Wed”
.判断 (星期 = “3”)
星期 = “Tue”
.判断 (星期 = “2”)
星期 = “Mon”
.默认
.判断结束
.判断开始 (月 = “1”)
月 = “Jan”
.判断 (月 = “2”)
月 = “Feb”
.判断 (月 = “3”)
月 = “Mar”
.判断 (月 = “4”)
月 = “Apr”
.判断 (月 = “5”)
月 = “May ”
.判断 (月 = “6”)
月 = “Jun”
.判断 (月 = “7”)
月 = “Jul”
.判断 (月 = “8”)
月 = “Aug”
.判断 (月 = “9”)
月 = “Sep”
.判断 (月 = “10”)
月 = “Oct”
.判断 (月 = “11”)
月 = “Nov”
.判断 (月 = “12”)
月 = “Dec”
.默认
.判断结束
返回 (星期 + “ ” + 月 + “ ” + 日 + “ ” + 时 + “:” + 分 + “:” + 秒 + “ CST ” + 年)

Related Posts: 易语言-CST时间函数 :