易语言对MySQL的操作中,增加记录也是有两种方法,下面分别列出(涉及的数据库在文章易语言-MySQL-select源码例程。):

.版本 2
.支持库 MySQL
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
.局部变量 SQL语句, 文本型
.局部变量 执行结果, 逻辑型
.局部变量 错误文本, 文本型
.局部变量 数据库句柄, 整数型
数据库句柄 = 连接MySql (“127.0.0.1”, “root”, “123456”, “wxpet_test”, 3306)
执行SQL语句 (数据库句柄, “set names 'gbk'”) ' 只有用gbk才可以写入中文哦~
.如果真 (数据库句柄 ≤ 0)
信息框 (“连接服务器错误!” + #换行符 + “请确认该服务器运行中并且你有连接该服务器的权限!”, 16, “连接服务器失败!”)
.如果真结束
' 第一种执行sql指令的方式
SQL语句 = “insert into pre_wxstorage (username,itemname,itemnums) values ('admin','测试数据',5)”
执行结果 = 执行SQL语句 (数据库句柄, SQL语句)
.如果 (执行结果 = 假)
取错误文本 (数据库句柄, 错误文本)
输出调试文本 (错误文本)
.否则
.如果结束
' 第二种利用更新记录执行
增加记录 (数据库句柄, “pre_wxstorage”, “username='admin',itemname='测试',itemnums=5”)
断开MySql (数据库句柄)

Related Posts: 易语言-MySQL-insert源码例程 :