之前说了php的,下面分别介绍易语言的。今天说一下易语言-MySQL-select查询的代码。
首先,支持可需要MySQL支持库,这样才可以。

先下载数据库文件,通过phpMyAdmin导入到本地数据库,后续的测试用例都以这个数据库为主。

导入完毕呢,新建个易语言的windows窗口程序,复制以下代码进去,运行即可。记得连接的参数密码账号修改为本地的。

.版本 2
.支持库 MySQL
.程序集 窗口程序集1
.程序集变量 数据库句柄, 整数型
.子程序 __启动窗口_创建完毕
.局部变量 SQL语句, 文本型
.局部变量 索引, 整数型
.局部变量 子记录集句柄, 整数型
.局部变量 itemname, 文本型
.局部变量 username, 文本型
.局部变量 执行结果, 逻辑型
.局部变量 错误文本, 文本型
数据库句柄 = 连接MySql (“127.0.0.1”, “root”, “123456”, “wxpet_test”, 3306)
.如果真 (数据库句柄 ≤ 0)
信息框 (“连接服务器错误!” + #换行符 + “请确认该服务器运行中并且你有连接该服务器的权限!”, 16, “连接服务器失败!”)
.如果真结束
' 第一种select方式
SQL语句 = “SELECT itemname,username FROM pre_wxstorage WHERE username='admin'”
执行结果 = 执行SQL语句 (数据库句柄, SQL语句)
.如果真 (执行结果 = 假)
取错误文本 (数据库句柄, 错误文本)
输出调试文本 (错误文本)
.如果真结束
子记录集句柄 = 取记录集 (数据库句柄)
.计次循环首 (取记录集行数 (子记录集句柄), )
读字段值 (子记录集句柄, “username”, username)
输出调试文本 (username)
读字段值 (子记录集句柄, “itemname”, itemname)
输出调试文本 (itemname)
到下一行 (子记录集句柄)
.计次循环尾 ()
释放记录集 (子记录集句柄)
' 第二种select方式
子记录集句柄 = 查找记录 (数据库句柄, “pre_wxstorage”, “itemname,username”, “username='admin'”, “”)
.计次循环首 (取记录集行数 (子记录集句柄), )
读字段值 (子记录集句柄, “username”, username)
输出调试文本 (username)
读字段值 (子记录集句柄, “itemname”, itemname)
输出调试文本 (itemname)
到下一行 (子记录集句柄)
.计次循环尾 ()
释放记录集 (子记录集句柄)
断开MySql (数据库句柄)

Related Posts: 易语言-MySQL-select查询源码例程 :