今天说一下易语言-Sql Server-select查询的代码,方法有不少,本文所述是使用了数据库操作支持库的方法。
首先,支持可需要数据库操作支持库,这样才可以。
选中所需的数据库操作支持库
添加完毕后,右侧会出现扩展组件栏,点击后,在窗体中添加一个记录集,一个数据库连接组件。
向窗体添加了记录集和数据库连接组件

启动sql server,进入管理的数据库,右键-所有任务-还原数据库
还原数据库示意图

还原为数据库:输入testdb,然后选择从设备,选择设备,添加,选择下载好的testdb文件。两次确定后,数据库还原完毕。下面可以开始程序对数据库的操作了。

select遍历结果等源码如下:

.版本 2
.支持库 eDB
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
.局部变量 username, 文本型
.如果 (数据库连接1.连接SQLServer (“(local)”, “testdb”, “sa”, “123456”) = 假)
信息框 (“连接本地数据库失败,请检查sa账号对应密码”, 0, “错误提示”)
.否则
记录集1.置连接 (数据库连接1)
' 下面这两句插入是因为数据表没有内容,所以插入数据后用于查询
记录集1.打开 (“INSERT INTO testtable (id, username, itemname) VALUES (1, 'test1', 'item1')”, #SQL语句, )
记录集1.打开 (“INSERT INTO testtable (id, username, itemname) VALUES (2, 'test2', 'item2')”, #SQL语句, )
记录集1.打开 (“select username from testtable where id>0”, #SQL语句, )
.判断循环首 (记录集1.尾记录后 = 假)
记录集1.读文本 (“username”, username)
输出调试文本 (username)
记录集1.到下一条 ()
.判断循环尾 ()
数据库连接1.关闭 ()
.如果结束

Related Posts: 易语言-Sql Server-insert,select查询源码例程 :