直接上源码了,不明所以的请参看之前写的博客-易语言-Sql Server-insert,select查询源码例程。

.版本 2
.支持库 eDB
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
.局部变量 username, 文本型
.局部变量 执行成功标志, 逻辑型
.如果 (数据库连接1.连接SQLServer (“(local)”, “testdb”, “sa”, “123456”) = 假)
信息框 (“连接本地数据库失败,请检查sa账号对应密码”, 0, “错误提示”)
.否则
记录集1.置连接 (数据库连接1)
执行成功标志 = 记录集1.打开 (“update testtable set username='0'+username where id>0”, #SQL语句, )
.如果真 (执行成功标志 = 假)
输出调试文本 (“更新错误”)
.如果真结束
数据库连接1.关闭 ()
.如果结束

Related Posts: 易语言-Sql Server-update源码例程 :