通常高于MySQL5.7的版本会在创建用户的时候出现这个提示。

这个其实与validate_password_policy的值有关。

validate_password_policy有以下取值:

PolicyTests Performed
0 or LOWLength
1 or MEDIUMLength; numeric, lowercase/uppercase, and special characters
2 or STRONGLength; numeric, lowercase/uppercase, and special characters; dictionary file

默认是1,即MEDIUM,所以刚开始设置的密码必须符合长度,且必须含有数字,小写或大写字母,特殊字符。

MySQL命令行下执行

set global validate_password_policy=0;

即可将判断密码的标准修改为基于密码的长度。
然后只要建立的长度足够的密码即可。

摘录自:http://www.cnblogs.com/ivictor/p/5142809.html

Related Posts: MySQL-phpMyAdmin Your password does not satisfy the current policy requirements :