易语言中MySQL的update可以用两种方式来对字段进行更新,下面就这两种方式贴出源码。涉及的数据库在文章易语言-MySQL-select源码例程。

.版本 2
.支持库 MySQL
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
.局部变量 SQL语句, 文本型
.局部变量 执行结果, 逻辑型
.局部变量 错误文本, 文本型
.局部变量 数据库句柄, 整数型
数据库句柄 = 连接MySql (“127.0.0.1”, “root”, “123456”, “wxpet_test”, 3306)
.如果真 (数据库句柄 ≤ 0)
信息框 (“连接服务器错误!” + #换行符 + “请确认该服务器运行中并且你有连接该服务器的权限!”, 16, “连接服务器失败!”)
.如果真结束
' 第一种执行sql指令的方式
SQL语句 = “update pre_wxstorage set username='testadmin' WHERE username='admin'”
执行结果 = 执行SQL语句 (数据库句柄, SQL语句)
输出调试文本 (“该指令影响” + 到文本 (取影响行数 (数据库句柄)) + “行”)
.如果真 (执行结果 = 假)
取错误文本 (数据库句柄, 错误文本)
输出调试文本 (错误文本)
.如果真结束
' 第二种利用更新记录执行
执行结果 = 更新记录 (数据库句柄, “pre_wxstorage”, “username='admin'”, “username='testadmin'”)
.如果真 (执行结果 = 假)
取错误文本 (数据库句柄, 错误文本)
输出调试文本 (错误文本)
.如果真结束
输出调试文本 (“该指令影响” + 到文本 (取影响行数 (数据库句柄)) + “行”)
断开MySql (数据库句柄)

Related Posts: 易语言-MySQL-update源码例程 :