下列代码就是遍历子目录的代码,其他文件自己举一反三。

.版本 2
.局部变量 文件名, 文本型
.局部变量 缓存字符串, 文本型
文件名 = 寻找文件 (“c:\*.*”, #子目录)
.如果真 (文件名 = “”)
返回 ()
.如果真结束
.循环判断首 ()
.如果真 (位与 (取文件属性 (文件名), #子目录) ≠ 0 且 文件名 ≠ “.” 且 文件名 ≠ “..” 且 文件名 ≠ “MEmu”)
输出调试文本 (文件名)
.如果真结束
文件名 = 寻找文件 (, #子目录)
.循环判断尾 (文件名 ≠ “”)

如您从本文得到了有价值的信息或帮助,请考虑扫描文末的二维码对我进行赞赏和鼓励。

与《易语言-遍历目录的子目录代码示例》相关的博文:


留言

Admin Avatar
😀
😀😁😂😅😭🤭😋😘🤔😰😱🤪💪👍👎🤝🌹👌