在特别的环境中,使用docker-compose启动容器时,会碰到报错:“ERROR: The Docker Engine version is less than the minimum required by Compose. Your current project requires a Docker Engine of version 1.10.0 or greater.”

根本原因是docker-compose版本过高,而一般这种特殊环境下的Docker版本(1.7.1)也因为内核原因而无法升级到更高版本,所以,降低docker-compose版本成了唯一可行方案。

降级docker-compose版本方法:

  1. 卸载docker-compose
    pip uninstall docker-compose
  2. 指定安装低版本docker-compose
    pip install docker-compose==1.5.2
  3. 之后,只需解决因版本差异造成的docker-compose.yml不兼容问题,就可以正常拉起容器了。这个就由你自己研究了。

参考资料:Docker Compose 版本过高(Docker版本不匹配),降低docker-compose版本



Related Posts: 如何降级docker-compose版本 :

留言