嗯,事情是这样的,要用swoole,然后安装嘛,之前yum装的php71,于是

yum install php-swoole

输出

Error: php71-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

于是尝试

yum install php-swoole --skip-broken

输出

Packages skipped because of dependency problems:
hiredis-last-0.13.3-1.el7.remi.x86_64 from remi-safe
php-common-5.3.29-1.8.amzn1.x86_64 from amzn-main
php-mysqlnd-5.3.29-1.8.amzn1.x86_64 from amzn-main
php-pdo-5.3.29-1.8.amzn1.x86_64 from amzn-main
php-pecl-swoole2-2.1.3-1.el7.remi.7.1.x86_64 from remi-php71
php71-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-cli-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-common-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-devel-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-fpm-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-gd-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-json-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-mbstring-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-mcrypt-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-opcache-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-pdo-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-pgsql-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-process-7.1.15-1.31.amzn1.x86_64 from amzn-main
php71-xml-7.1.15-1.31.amzn1.x86_64 from amzn-main

???什么鬼?这特么什么情况= =于是我的知识范畴就到此为止了,我查了谷歌重建缓存啥的也没见好~

这个时候怎么办?那必须找老大了,浩哥出马,立马解决……
老大分析原因是:amzn-main.repo出了问题
amzn-main.repo 这里国内aws源里面得包几百年不更新,移除掉就行了。
可以这样搞:

mv /etc/yum.repos.d/amzn-main.repo /opt/amzn-main.repo

移动备份到opt下面。

yum install php-swoole --skip-broken

就可以安装了。

Related Posts: AWS yum安装的奇葩事 :

留言

avatar