这篇文章是在linux下搭建github遇到问题而来。

以下内容根据【香菇】童鞋反馈,修正了需要修改的文件名,感谢他~

出现这问题是由于这网站被墙了导致的,FUCK~~~解决办法嘛,我是安装git的时候遇到的,所以附上针对git中的解决办法:
1.编辑

/home/git/gitlab/Guardfile
/home/git/gitlab/gemfile

修改第一行中的

source "https://rubygems.org"

改为:

source "https://ruby.taobao.org"

2.编辑

/home/git/gitlab/Guardfile.lock
/home/git/gitlab/gemfile.lock

修改第16行中的

remote: https://rubygems.org/

改为:

remote: https://ruby.taobao.org/

如此,就使用了淘宝的源,会很方便。

ruby淘宝源网址:http://ruby.taobao.org/


如您从本文得到了有价值的信息或帮助,请考虑扫描文末的二维码对我进行赞赏和鼓励。

与《Bundler::HTTPError Could not fetch specs from https://rubygems.org/》相关的博文:


发布时间 09/21/2014 09:14:01所属栏目 Software.所属标签 .

8
留言

Admin Avatar
😀
😀😁😂😅😭🤭😋😘🤔😰😱🤪💪👍👎🤝🌹👌
seven
seven

ruby 的淘宝源网址 过期了 现在是 https://ruby.taobao.org/

啦啦乱
啦啦乱

thx,一开始加了淘宝source没有改.lock文件,现在总算可以下了。。