呐,最近偶尔玩儿一个node的项目,初始化的时候碰到这么个报错,当然,有精确的两个包名。

那么碰到类似:

npm WARN @angular/cdk@2.0.0-beta.10 requires a peer of @angular/core@^4.3.0 but none is installed. You must install peer dependencies yourself.

这样的报错如何处理呢?

当然是面向谷歌找答案了~以上面的报错新为例,解决方案如下:

  1. 根据报错得到包名信息:@angular/core@^4.3.0
  2. 执行安装指令:
    npm install --save-dev "@angular/core@^4.3.0"

参考资料

npm WARN … requires a peer of … but none is installed. You must install peer dependencies yourself


如您从本文得到了有价值的信息或帮助,请考虑扫描文末的二维码对我进行赞赏和鼓励。

与《npm WARNrequires a peer of but none is installed. 解决方案》相关的博文:


发布时间 07/28/2021 07:04:57所属栏目 Software.所属标签 .

留言

avatar
😀
😀😁😂😅😭🤭😋😘🤔😰😱🤪💪👍👎🤝🌹👌