最初搜了下,说是3.0之后才支持集群,由于生产环境的PHP是5.2.17,于是各种尝试,各种装不上,偶然检索解决方案,在https://github.com/phpredis/phpredis/issues/884 看到作者说其实2.2.8和3.0一样,只不过3.0支持PHP7而已。

卧槽……早说啊,2.2.8的安装很流畅的好吧,低版本的PHP顶多注释几句话就能正常安装,安装后,测试代码如下:

set("say",array("hello world"));    
var_dump($redis->get("say"));

早说2.2.8支持集群啊,用俩小时,上吊的心情都有了……


如您从本文得到了有价值的信息或帮助,请考虑扫描文末的二维码对我进行赞赏和鼓励。

与《PHP的Redis 扩展 支持集群的版本》相关的博文:


留言

Admin Avatar
😀
😀😁😂😅😭🤭😋😘🤔😰😱🤪💪👍👎🤝🌹👌