最近想把PNG转BMP,用易语言怎么实现呢?示例代码如下:

.版本 2

.子程序 _按钮1_被单击
.局部变量 BMP数据, 字节集

BMP数据 = PNG转BMP (读入文件 (“C:\test.png”), 画板1, #白色)
写到文件 (“C:\dump.bmp”[......]

阅读全文

有时会有中英文混合文本,拆分的话,普通拆分可是会因为中文英文长度占用字节不同而出现乱码,这个时候就需要使用额外的函数逐字分割才能得到正确的结果,源码如下:

.版本 2
.子程序 逐字分割
.参数 欲取的内容, 文本型, , 欲取的内容
.参数 返回的数组, 文本型, 数组,[......]

阅读全文

假设我们有了两个日期时间型的变量,想得到二者之间间隔天数,如何处理?此时就需要使用函数:取时间间隔。

调用格式: 〈双精度小数型〉 取时间间隔 (日期时间型 时间1,日期时间型 时间2,整数型 取间隔部分) – 系统核心支持库->时间操作
英文名称:TimeDiff[……]

阅读全文

假设我们有了一个日期时间型的变量,想得到一天后的时间,如何处理?此时就需要使用函数:增减时间。

调用格式: 〈日期时间型〉 增减时间 (日期时间型 时间,整数型 被增加部分,整数型 增加值) – 系统核心支持库->时间操作
英文名称:TimeChg
返回一个时间,这一[……]

阅读全文