下列代码就是遍历子目录的代码,其他文件自己举一反三。

.版本 2
.局部变量 文件名, 文本型
.局部变量 缓存字符串, 文本型
文件名 = 寻找文件 (“c:\*.*”, #子目录)
.如果真 (文件名 = “”)
返回 ()
.如果真结束
.循环判断首 ()
.如果真 (位与 (取文件[......]

阅读全文

下列代码是网上搜的改的,竟然是调用goto来跳出循环的,囧,有需要的凑合用喽~

@echo off
set num=0
:ok
set /a num+=1
echo 这是一个循环,已循环%num%次
if "%num%"=="200" pause &&[......]

阅读全文

这个需求其实是因为有一个备份数据库,一个待还原的数据库,需要还原部分数据,其实默认用PDOselect出来的数据,写入的时候直接update过去就可以了。
示例代码:

<?php
$rs = $olddb->query("SELECT blobdata FROM `[......]

阅读全文

BLOB是二进制的数据,所以读取和写入方式还不太一样,所以记录下:

<?php
$c="content";
$blobcontent = bin2hex(gzcompress($c)

这样得到的数据,就可以作为字符串写入到数据库了。

提取的话,提取出来的话这样提取:[……]

阅读全文

ThinkPad X240 未知设备 VID_8086的情况,这玩意儿就是个USB3.0的驱动没装导致的,下载驱动解压安装即可。
驱动下载地址:ThinkPad X240 未知设备 VID_8086.zip[……]

阅读全文

nginx搭建的网站,遇到一些图片404的,打算用默认的404图片,规则怎么写呢?看如下示例:

location /img {
location ~ ^/img/([_-a-zA-Z0-9]*) {
error_page 404 /img/404.jpg;
}
}

规则整理自:http:[……]

阅读全文

随便测试了下,如下代码是有效的:

setCookie("lastime",$selectlogin['lastime'],0,'/');

通过这样方式设置的Cookies是可以随浏览器关闭自动销毁的。

整理自:http://my[……]

阅读全文